Check if your device meets the system requirements:


For Android - Required Android 6.0 or later.


For iOS Compatibility

iPhone - Requires iOS 14.2 or later.

iPad - Requires iPadOS 14.2 or later.

iPod Touch - Requires iOS 14.2 or later.

Apple TV - Requires tvOS14.2 or later.


If your phone meets the following, please be sure your internet or your data is working properly.

While on mobile data, try toggling off and on to refresh the connection. You can also restart your device to get a fresh install. This usually solves the problem. 


Need More Support?

Send us an email at support@reveel.net any time.